You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

22 lines
547 B
Nix

{
description = "A very basic flake";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
let
ffnixModule = import ./.;
in {
overlay = final: prev: {
batman-adv-legacy = kernelPackages: kernelPackages.callPackage ./batman-adv-legacy.nix {};
batctl-legacy = final.callPackage ./batctl-legacy.nix {};
};
overlays = [ self.overlay ];
nixosModules.ffnix = ffnixModule;
nixosModule = ffnixModule;
};
}